您所在位置:首页 > 科学

通达信带F10资料的主图指标公式介绍

2018-01-10 09:35:10 来源:吉安资讯网 标签:所属 数据 每股

  M1:=5;M2:=20;M3:=60;M4:=120;财务数据:=1;BS:1,NODRAW;MA1:MA(CLOSE,M1)COLORWHITE,LINETHICK1;MA2:MA(CLOSE,M2)COLORYELLOW,LINETHICK1;MA3:MA(CLOSE,M3)COLORMAGENTA,LINETHICK2;MA4:MA(CLOSE,M4)COLORGREEN,LINETHICK2;CC:IF(CURRBARSCOUNT《18,CONST(REF(C,1)),DRAWNULL),COLORMAGENTA;止赢:1.05*CC,COLOR8000FF;止损:0.97*CC,COLOR00F000;V1:=ABS((2*CLOSE HIGH LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);V2:=(1-7/100)*(DMA(CLOSE,V1));V3:=(1 7/100)*(DMA(CLOSE,V1));V5:=MA((LOW HIGH CLOSE)/3,5);支撑:REFDATE(V2,DATE),DOTLINE,LINETHICK1,COLORFF0080;阻力:REFDATE(V3,DATE),DOTLINE,LINETHICK1,COLOR676767;AAA:=CONST(HHV(H*0.5,90));AA:=(REF(CLOSE,1) REF(CLOSE,2) OPEN)/3;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.8,0.05,1,‘今日保护价’),LINETHICK2,COLOR00FFFF;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.84,0.05,1,AA);DRAWTEXT_FIX(CURRBARSCOUNT=1,0.86,0.05,1,‘元’);PT:=REF(H,1)-REF(L,1);CDP:=(REF(H,1) REF(L,1) REF(C,1)*2)/4;AH:=CDP PT;AL:=CDP-PT;NH:=CDP*2-REF(L,1);NL:=CDP*2-REF(H,1);强:IF(AH》REF(C,1)*1.1,REF(C,1)*1.1,AH)NODRAW;阻:IF(NH》强,(强-CDP)*0.618 CDP,NH)NODRAW,COLORBLUE;M:=IF(AL《REF(C,1)/1.1,REF(C,1)/1.1,AL);撑:IF(NL《M,CDP-(CDP-M)*0.618,NL)NODRAW;底:IF(AL《REF(C,1)/1.1,REF(C,1)/1.1,AL)NODRAW;总股本:=STRCAT(STRCAT(‘总股本:’,CON2STR(TOTALCAPITAL/1000000,2)),‘亿’)*财务数据;流通盘:=STRCAT(STRCAT(‘流通盘:’,CON2STR(CAPITAL/1000000,2)),‘亿’)*财务数据;全流通:=STRCAT(‘全流通:’,CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2))*财务数据;市值:=STRCAT(STRCAT(‘流通市值:’,CON2STR((CAPITAL/1000000)*C,2)),‘亿’)*财务数据;上市天数:=STRCAT(‘上市天数:’,CON2STR(FINANCE(42),0))*财务数据;股本市值:=STRCAT(‘股本市值:’,STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),上市天数))*财务数据;市盈率:=STRCAT(‘市盈率:’,CON2STR(C/FINANCE(33),2))*财务数据;市销率:=STRCAT(‘市销率:’,CON2STR(C/(FINANCE(20)/FINANCE(1)),2))*财务数据;市净率:=STRCAT(‘市净率:’,CON2STR(C/FINANCE(34),2))*财务数据;净资收益率:=STRCAT(‘净资收益率:’,CON2STR(FINANCE(33)/FINANCE(34)*100,2))*财务数据;毛利率:=STRCAT(‘毛利率:’,CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2))*财务数据;净利润率:=STRCAT(‘净利润率’,CON2STR(FINANCE(30)/FINANCE(20)*100,2))*财务数据;主营利润率:=STRCAT(‘主营利润率’,CON2STR(FINANCE(23)/FINANCE(20)*100,2))*财务数据;当前业绩:=STRCAT(‘当前业绩:’,STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市盈率,市销率),市净率),净资收益率),毛利率),净利润率),主营利润率))*财务数据;X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;X2:=(FINANCE(31) FINANCE(17))/FINANCE(10)*1.4;X3:=FINANCE(23)/FINANCE(10)*3.3;X4:=FINANCE(19)/FINANCE(15)*0.6;X5:=FINANCE(20)/FINANCE(15)*0.999;Z值:=X1 X2 X3 X4 X5;预警:=IF(Z值《1.2,‘重警’,IF(Z值》=1.2ANDZ值《2.6,‘轻警’,‘无警’))*财务数据;财务预警:=STRCAT(‘财务预警:’,STRCAT(预警,STRCAT(‘-Z值:’,CON2STR(Z值,3))))*财务数据;优质资产率:=STRCAT(‘优质资产率:’,CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2))*财务数据;现金负债比:=STRCAT(‘现金负债比:’,CON2STR(FINANCE(25)/FINANCE(15),3))*财务数据;财务系数:=STRCAT(‘风险系数:’,STRCAT(STRCAT(财务预警,优质资产率),现金负债比))*财务数据;DRAWTEXT_FIX(ISLASTBAR,0.00,0.12,0,股本市值),COLORGREEN;DRAWTEXT_FIX(ISLASTBAR,0.00,0.18,0,当前业绩),COLORGREEN;DRAWTEXT_FIX(ISLASTBAR,0.00,0.24,0,财务系数),COLORGREEN;DRAWTEXT_FIX(1,0.00,0,0,‘所属地区:’)COLOR00FFFF;DRAWTEXT_FIX(1,0.07,0,0,DYBLOCK)COLOR00FFFF;DRAWTEXT_FIX(1,0.00,0.06,0,‘所属行业:’)COLORFF00FF;DRAWTEXT_FIX(1,0.07,0.06,0,HYBLOCK)COLORFF00FF;今日保护价:(REF(C,2) REF(C,1) O)/3,COLORCC3299,NODRAW;顶点:IF(CURRBARSCOUNT《=60,CONST(IF(ISLASTBAR=1,HHV(H,BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORRED,DOTLINE;低点:IF(CURRBARSCOUNT《=60,CONST(IF(ISLASTBAR=1,LLV(L,BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORMAGENTA,DOTLINE;DRAWTEXT(ISLASTBAR,顶点,‘顶点’),COLORRED;DRAWTEXT(ISLASTBAR,低点,‘低点’),COLORMAGENTA;MA7:=MA(CLOSE,BS);转强:=(6*H 5*REF(H,1) 4*REF(H,2) 3*REF(H,3) 2*REF(H,4) 1*REF(H,5))/(6 5 4 3 2 1);转弱:=(6*L 5*REF(L,1) 4*REF(L,2) 3*REF(L,3) 2*REF(L,4) 1*REF(L,5))/(6 5 4 3 2 1);BB2:=IF(C》REF(转强,1),1,IF(C《REF(转弱,1),-1,0));DD2:=BARSLAST(NOT(BB2=0));B:=IF(BB2=0,REF(BB2,DD2),BB2);中短:=IF(B=-1,MA(HIGH,6),MA(LOW,6));STICKLINE(MA7《中短,LOW,HIGH,0,1),COLORCYAN;STICKLINE(MA7》中短,LOW,HIGH,0,1),COLORRED;STICKLINE(((OPEN》CLOSE)AND(MA7《中短)),(CLOSE-0.003),OPEN,3.1,0),COLORLIBLUE;STICKLINE(((OPEN《CLOSE)AND(MA7《中短)),CLOSE,OPEN,3.1,1),COLORCYAN;STICKLINE(((OPEN》CLOSE)AND(MA7》中短)),OPEN,(CLOSE-0.003),3.1,0),COLORRED;STICKLINE(((OPEN《CLOSE)AND(MA7》中短)),OPEN,CLOSE,3.1,1),COLORRED;B点:CROSS(MA7,中短),COLORRED,NODRAW;持股:MA7》中短,COLORRED,NODRAW;DRAWICON(CROSS(MA7,中短),L,7);DRAWICON(CROSS(中短,MA7),H,8);超B:=L2_AMO(0,2)/10000.0;大B:=L2_AMO(1,2)/10000.0;中B:=L2_AMO(2,2)/10000.0;小B:=L2_AMO(3,2)/10000.0;超S:=L2_AMO(0,3)/10000.0;大S:=L2_AMO(1,3)/10000.0;中S:=L2_AMO(2,3)/10000.0;小S:=L2_AMO(3,3)/10000.0;

相关资讯

  • 跟苏东坡门当户对的亲戚
  • 男子因急于存钱与保安认罪起非法被捅5刀
  • 全省2017年全省“小目标”:浙江省消除劣V类农业转型
  • 男子不一样哭泣女子邀人砍死其别的
  • 百元错币水印毛泽东头像眼睛眯成一条线(图)
  • 餐具让小董舔食公共堂员工称会喂狗(图)
  • 全国政协十二届常委会第十九次会议开幕俞正声出席
  • 刘强东一“怒”之下说了这句话